首页 » 技术资讯 » 原创视频 » 【干货|誉天易消愁说网络】华为RS实验漫载(三)—MPLS VPN骨干网IGP及MPLS

【干货|誉天易消愁说网络】华为RS实验漫载(三)—MPLS VPN骨干网IGP及MPLS

配置及解析:

下面是一个MPLS VPN的典型组网配置实例。

MPLS VPN_1

1.首先将MPLS骨干网基础配置完成,使用isis协议实现全网通。接口地址如下表:

设备 接口 地址
R1 GigabitEthernet 0/0/0 10.1.12.1/24
R1 LoopBack 0 1.1.1.1/32
R2 GigabitEthernet 0/0/0 10.1.12.2/24
R2 GigabitEthernet 0/0/1 10.1.23.2/24
R2 LoopBack 0 2.2.2.2/32
R3 GigabitEthernet 0/0/0 10.1.23.3/24
R4 LoopBack 0 3.3.3.3/32

 

R1配置:

<Huawei>system-view     //进入系统视图

[Huawei]sysname R1     //修改设备名称

[R1]isis 1     //进入isis进程

[R1-isis-1]is-level level-2     //修改isis级别

[R1-isis-1]network-entity 49.0123.0000.0000.0001.00     //配置isis进程的网络实体名称NET

[R1]interface GigabitEthernet 0/0/0

[R1-GigabitEthernet0/0/0]ip address 10.1.12.1 24

[R1-GigabitEthernet0/0/0]isis enable 1     //接口使能isis

[R1]interface LoopBack 0

[R1-LoopBack0]ip address 1.1.1.1 32

[R1-LoopBack0]isis enable 1

 

R2配置:

<Huawei>system-view

[Huawei]sysname R2

[R2]isis 1

[R2-isis-1]is-level level-2

[R2-isis-1]network-entity 49.0123.0000.0000.0002.00

[R2]interface GigabitEthernet 0/0/0

[R2-GigabitEthernet0/0/0]ip address 10.1.12.2 24

[R2-GigabitEthernet0/0/0]isis enable 1

[R2]interface GigabitEthernet 0/0/1

[R2-GigabitEthernet0/0/1]ip address 10.1.23.2 24

[R2-GigabitEthernet0/0/1]isis enable 1

[R2]interface LoopBack 0

[R2-LoopBack0]ip address 2.2.2.2 32

[R2-LoopBack0]isis enable 1

 

R3配置:

<Huawei>system-view

[Huawei]sysname R3

[R3]isis 1

[R3-isis-1]is-level level-2

[R3-isis-1]network-entity 49.0123.0000.0000.0003.00

[R3]interface GigabitEthernet 0/0/0

[R3-GigabitEthernet0/0/0]ip address 10.1.23.3 24

[R3-GigabitEthernet0/0/0]isis enable 1

[R3]interface LoopBack 0

[R3-LoopBack0]ip address 3.3.3.3 32

[R3-LoopBack0]isis enable 1

 

检查现象:配置完成后在R1、R2、R3上查看公网路由表是否有MPLS骨干域路由。执行display ip routing-tablel命令可以看到每台设备上都有MPLS骨干域全网路由。

MPLS VPN_2

MPLS VPN_3
MPLS VPN_4

2.在MPLS骨干网上配置MPLS基本能力和MPLS LDP,在互联设备的接口上使能MPLS及LDP,建立LSP和实现MPLS报文转发。

R1配置:

[R1]mpls lsr-id 1.1.1.1     //配置LSR的ID

[R1]mpls     //使能MPLS

[R1]mpls ldp     //使能MPLS LDP

[R1]interface GigabitEthernet 0/0/0

[R1-GigabitEthernet0/0/0]mpls     //接口使能MPLS

[R1-GigabitEthernet0/0/0]mpls ldp     //接口使能MPLS LDP

 

R2配置:

[R2]mpls lsr-id 2.2.2.2

[R2]mpls

[R2]mpls ldp

[R2]interface GigabitEthernet 0/0/0

[R2-GigabitEthernet0/0/0]mpls

[R2-GigabitEthernet0/0/0]mpls ldp

[R2]interface GigabitEthernet 0/0/1

[R2-GigabitEthernet0/0/1]mpls

[R2-GigabitEthernet0/0/1]mpls ldp

 

R3配置:

[R3]mpls lsr-id 3.3.3.3

[R3]mpls

[R3]mpls ldp

[R3]interface GigabitEthernet 0/0/0

[R3-GigabitEthernet0/0/0]mpls

[R3-GigabitEthernet0/0/0]mpls ldp

 

检查现象:配置完成后R1与R2,R2    与R3之间可以建立LDP会话,执行display mpls ldp session命令可以看到显示结果中Status项为“Operational”。 执行display mpls ldp lsp命令,可以看到LDP LSP的建立情况。

MPLS VPN_5

MPLS VPN_6


下一节,我们将对VPN实例及实例内路由做配置讲解

誉天教育,专业从事华为ICT人才培训。主攻实战型ICT人才培养,作为各大高校和知名企业的传输钮,不仅为众多高校解决了大学生毕业即失业的问题,更为企业解决了用人难,用技术型人才更难的问题。誉天在技术方向的致力,一直是华为认可,学员认可的优质品牌!

本文由誉天数通讲师易老师整理,易老师熟练交换网络中的各项技术、路由协议和配置、网络访问的控制;曾为武汉出版社部署无线覆盖、宜昌林业局网络调试;有着丰富的网络调试及运维经验。实战经验十足,解常人不能解之忧,消常人不能消之愁!

 

更多